InCD not running (Full Version)

All Forums >> [Optical Storage Software] >> CD/DVD Authoring >> Packet Writing


wolfv -> InCD not running (3/12/2003 7:27:04 PM)

I just installed InCD and rebooted win 2000.

InCD does not seem to be running. There is no a splash screen or symbol in the System Tray to indicate that InCD is running. There is no “Easy write reader” or “InCD” in the Windows Task Manager.

Nero 5.10 seems to work fine.

Why is InCD not running? How do I troubleshoot this bugger?

Thank you,

P.S. I saw on that Hewlett Packard CD-RW 8250 is listed in “recorders supported by Nero” but my Hewlett Packard CD-RW 8250i is not listed. Does the letter “i” at the end matter? Nero Burning works fine.

KCK -> RE: InCD not running (3/13/2003 1:18:07 AM)

Are you running Nero and InCD 3.52.20b? If not, download them from (no need for uninstalling previous versions first unless they are really old). Similarly for EasyWriteReader (get the latest one from Ahead's InCD | Utilities page).

If you have installed InCD 3.52.20b already, maybe the downloaded file was corrupted, so download and install it again. First, however, clean up your TMP and TEMP directories, and stop all unnecessary programs via Task Manager; also disable your antivirus software.

Indeed, only HP CD-RW+ 8250 is listed, but 8250i should be supported by InCD as well, since Nero works with it.

Anyway, once InCD is installed, you should see its icon in the System Tray even if you don't have any burner connected, so your installation must be broken. If you are curious, you could try running InCD.exe from C:\Program Files\Ahead\InCD to see if the icon appears, but this won't fix anything.

If you still have installation problems, come back and report the error messages, if any.

wolfv -> RE: InCD not running (3/15/2003 9:58:16 AM)

Thanks KCK.
I got InCD to run[:)], but then it freezes Win2000[xx(]. So I read about InCD troubleshooting under Win2K
It says

“burning plugins installed "silently" by other applications (e.g., Windows Media Player, WinAmp, RealPlayer, etc). Such applications typically install drivers conflicting with InCD”

Does that mean I can have InCD or multimedia, but not both[?]


Tron -> RE: InCD not running (3/15/2003 2:22:17 PM)

I always had troubles with InCD, but thought they had those resolved with the newer versions....

KCK -> RE: InCD not running (3/15/2003 2:35:00 PM)

It depends on what you mean by "multimedia".

You can have InCD together with WMP, WinAmp and RealPlayer, provided that you don't install their burning plugins.

wolfv -> RE: InCD not running (3/16/2003 11:22:22 AM)

How can I check if burning plugins (for Windows Media Player, WinAmp, RealPlayer, etc) are installed on my PC? Would they be listed in Add/Remove Programs?

wolfv -> RE: InCD not running (3/16/2003 12:37:09 PM)

Thank you.

wolfv -> RE: InCD not running (3/16/2003 12:38:34 PM)

I previously had Roxio 4 installed, then NTI CD Creator 6 installed. Both are now uninstalled and Nero InCD is installed. I am now trying to identify bad drivers.
I found the following files in my command window. Could you please tell me which files I should delete from my registry?

dir C:\WinNT\System32\Drivers\cd*.*

dir C:\WinNT\System32\Drivers\ud*.*

dir C:\WinNT\System32\cd*.*

dir C:\WinNT\System32\ud*.*
File Not Found

Thank you.

KCK -> RE: InCD not running (3/16/2003 5:12:54 PM)


Yes, you do have Roxio's remnants Cdr4_2k.sys and Cdralw2k.sys, and apparently some other rubbish which should be removed. For safety, however, we first need some more info.

Take a look at the recently updated version of the InCD guide

especially S11.1, S11.3, S11.5 and Q1 through Q12 in S18. In particular, we need the Driver Information section from Nero InfoTool (see Q11 in S18). To save your time, you may post the whole InfoTool report (click the diskette button to save it to a file); I'll tell you later which parts may be deleted (you can edit your previous posts via the third icon) to save the forum space.

As for your latest message, please repost your dir info in full version (with file dates and sizes; see S11.1), since this may help in proper identification of these .sys and .dll files.

I couldn't find anything on your cdsys.dll, so I'm wondering whether its name is correct.

Cdantsrv.exe comes from C-dilla Licence System, and apparently cdant.sys is related, but cdant.sys also comes with VirtualDrive; so do you know their origin?

Cd_clint.dll is part of spyware for ad servers (installed by KaZaa and IMESH, and also by more respectable applications). Well, it may not conflict with InCD, but I wouldn't recommend running spyware on your box! Search with Google for ways of removing such spyware.

To sum up, I believe your system can be cleaned, but it's better to identify all possible culprits first.

wolfv -> RE: InCD not running (3/18/2003 5:19:17 AM)

Below is what I have done since my last post. Sorry it took me so long to reply. This is my first time dealing with a the registry, so please tell me if you need more information:

I uninstalled KaZaA (iMesh is still on).

I read the InCD guide.

I used RegCleaner to remove KaZaA registries.

I did not find Roxio drivers Cdr4_2k.sys and Cdralw2k.sys on RegCleaner

I used Regedit.exe to find Roxio drivers Cdr4_2k.sys and Cdralw2k.sys in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs\

I used Regedt32.exe to backup HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SharedDLLs

I used Regedt32.exe to delete Cdr4_2k.sys and Cdralw2k.sys.

I ran Ad-aware6, found two data mining programs, they are harmless.
My system:

I have AutoDesk software installed, which uses the C-dilla License System.

Hewlett Packard CD-RW 8250i - driver included in Win2000
IDE Primary Slave?

BioStar Motherboard driver for AMD chipset – CD

Windows 2000 sp3

Nero - works correctly
InCD35220b - drag and drop freezes W2K, eject CD-WR from explore does not work.

Two Memorex CD-RW 4x 650mb fully erased before formatting.

CD-WR Format: UDF 1.50

Nero InfoTool:
Autorun on
ASPI file(s) are missing

Nero InfoTool report:
Driver Information
Driver : amd751
Description : AMD Win 2000 AGP Filter
Version : 5.00
Company : AMD Corporation

Driver : BsUDF
Description : UDF File System Driver (Windows2000)
Version :
Company : ahead software

Driver : Cdr4_2K
Description : CDR4_2k CDR Helper
Version : 2.5 (087)
Company : Adaptec

Driver : Cdralw2k
Description : CDRAL for Windows 2000 Kernel Driver
Version : 1.00 (1028)
Company : Adaptec

Driver : dmio
Description : NT Disk Manager I/O Driver
Version : 2191.1.296.2
Company : VERITAS Software Corp.

Driver : dmload
Description : NT Disk Manager Startup Driver
Version : 2191.1.296.2
Company : VERITAS Software Corp.

Driver Driver : incdrm
Description : remapper
Version :
Company : Ahead Software AG

Driver : Rdbss
Description : Redirected Drive Buffering SubSystem

Driver : roff
Description : Dantz Development Corporation Retrospect Open File Filter
Version : 6.0.113
Company : Dantz Development Corporation

ASPI Information
System ASPI

Thank you for your help.

wolfv -> RE: InCD not running (3/18/2003 5:28:47 AM)

There is an error in the above post, the CD-WR should read

Hewlett Packard CD-RW 8250i -
IDE secondary master
driver included in Win2000

I can not edit my previous posts; there is no third icon. My browser shows two icons - Show Profile and Reply with Quote. Am I looking in the right place?

Thank you.

wolfv -> RE: InCD not running (3/18/2003 8:19:50 AM)

Redownloaded and reinstalled both Nero and InCD.

InCD partly works.

Drag and drop to CD-WR works in Explorer.[^]

Eject CD from Explorer does not work.[V]
Ejected via eject button on CD hardware works.[^]

Nero is not working with UDF formatted CD.[V]

Inserted UDF formatted CD4, message:
“You can use this disc as you would use a floppy disc.
The disc was mounted in InCD UDF format.”

Error message when I try to open Nero:
Nero – Burning Rom
InCD currently accesses one or more recorders.
Please eject these CDs and then restart Nero.

Inserted regular formatted CD2, worked normally on Nero.

Any suggestions on what to trouble shoot next?


wolfv -> RE: InCD not running (3/18/2003 6:05:06 PM)

Repost of my dir info in full version (with file dates and sizes)
dir C:\WinNT\System32\Drivers\cd*.*
07/18/2002 57,968 CDANT.SYS
07/18/2002 46,080 CDANTSRV.EXE
12/10/1999 19,088 cdaudio.sys
12/10/1999 61,072 cdfs.sys
02/18/2003 52,720 cdr4_2k.sys
02/18/2003 22,585 cdralw2k.sys
12/10/1999 27,376 cdrom.sys

dir C:\WinNT\System32\Drivers\ud*.*
12/10/1999 61,488 udfs.sys

dir C:\WinNT\System32\cd*.*
08/29/2002 142,336 cdfview.dll
12/10/1999 68,368 cdm.dll
12/10/1999 402,704 cdonts.dll
12/10/1999 2,450,192 cdsys.dll
12/10/1999 337,680 cdplayer.exe
01/12/2002 48,640, cd_clint.dll

dir C:\WinNT\System32\ud*.*
File Not Found

Searched Cdr4_2k.sys again (thought I had deleted that before), found in:
HKEY_USERS\S-1-5-21-790525478-746137067-1708537768-500\Software\Microsoft\InternetExplorer\Elplorer Bars\{C4EE31F3-4768-11D2-BE5C-00A0C9A83DA1}\FilesNameMRU\Cdr4_2k.sys
Should I delete this Cdr4_2k.sys from the registry?

Regedit.exe search did not find Cdralw2k.sys.

Thank you.

KCK -> RE: InCD not running (3/18/2003 7:24:08 PM)

I saw your latest post when I tried to upload my answer to your previous three posts. I'll only add a comment at the end, leaving the rest as it was before your post.


Let's start with the first of your three latest posts.

You should have renamed Cdr4_2k.sys and Cdralw2k.sys in C:\WinNT\System32\Drivers before running RegClean (see S11.3; we'll come back to this point later).

As for your Nero InfoTool report, you have DMA off for both the burner and the CD-ROM drive on the secondary channel; I'm not sure if your burner can work with DMA on, but you could try this later (it might not matter for the burner, but you could get higher reading speeds for the CD-ROM drive).

Concerning Driver Information, you still have Cdr4_2k and Cdralw2k (which will have to be removed), but the rest looks OK; in particular, the VERITAS drivers dmio and dmload are legitimate under W2K. Well, I'm not quite sure about Dantz Retrospect's roff, but it may be harmless. BTW, incdrm comes from EasyWriteReader, which you forgot to mention earlier!

As for ASPI Information, apparently your System ASPI is Adaptec's ASPI 4.60, but I don't know why only Wnaspi32.dll is listed, so could you check whether Nero InfoTool | ASPI | System shows only this file and says "System ASPI is installed and working correctly"?

You may now prune down the Nero InfoTool report by deleting from the beginning till Driver Information, then all the Microsoft drivers and .dll entries.

As for why you couldn't edit your previous posts, maybe you were not logged in? When I'm logged in, my previous posts have five icons: Show Profile, Email Poster, Edit Reply, Reply with Quote, Delete Reply.

Concerning your latest post, I gather you upgraded to Nero, and just reinstalled InCD 3.52.20b. Did you also reinstall EasyWriteReader? The version you had been running before looked OK, so I'm simply asking for clarification.

I presume you were able to format fresh or fully-erased discs; please don't skip such information!

Do you mean that you don't see the Eject option in Explorer, or that nothing happens when you select it? Similarly for the InCD icon; did you try to use it? Recall that ejecting via the burner's button can be dangerous; see the WARNING in S8 again!

The Nero message you saw is perfectly normal: you should eject the disc first, call Nero so that it takes over your burner from InCD (which normally controls it), and then insert the disc. In general, Nero can record to blank (or erased) discs only, and Nero can be used to erase discs. In other words, if you want to use a previously formatted disc for recording in Nero, you must erase it first.

Further troubleshooting will need the following steps.

In C:\WinNT\System32\Drivers, rename Cdr4_2k.sys to Cdr4_2k.sy_ and Cdralw2k.sys to Cdralw2k.sy_. Before rebooting, call Regedit (or Regedt32 if you prefer) and search for "lowerfilters" (without the quotes). Click on the key in the left pane, and back it up for safety. Then in the right pane delete the entries for Cdr4_2k and Cdralw2k in LowerFilters and/or UpperFilters, if any. Finally, close Regedit and reboot.

Next, check how InCD operates after these changes. For instance, try to format a blank or erased disc, and tell us if everything proceeds as in S8; if you see any discrepancies, report them in detail. Then copy some files to the disc, and try to eject it via the InCD icon; if this works, insert the disc again, note if the InCD mounted message pops out, then try to eject it via Explorer.

If you still have problems, again we will need more information, especially after all the recent changes. So please post the full results of the four dir commands described in S11.1, and the Driver Information section from Nero InfoTool (without the Microsoft drivers and .dll files to save space).


This refers to your latest message.

Thanks for the full dir outputs; just as I thought, Cdr4_2k and Cdralw2k are still present.

Concerning your registry, you should have searched for cdr4_2k, not for cdr4_2k.sys, and similarly for cdralw2k.

As indicated above, the two Roxio culprits should be renamed and purged from LowerFilters and UpperFilters. Afterwards, you may delete them from the registry either manually or via RegClean.

wolfv -> RE: InCD not running (3/18/2003 10:48:08 PM)

Thanks KCK. I am working on your suggestions.
How do I turn on DMA (Direct Memory Access)? Is it in BIOS?


KCK -> RE: InCD not running (3/19/2003 12:31:41 AM)

Enabling DMA is not a priority in you case; I just mentioned it because I had seen you had DMA off. Anyway, take a look in the FAQ's forum on for a guide with pictures.

Still, it's unlikely that having DMA off could influence your InCD problems, so you may play with DMA later.

Page: [1] 2   next >   >>

Valid CSS!

Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI