CDRInfo Forum CDRInfo Forum

Forums  Register  Login  My Profile  Inbox  Address Book  My Subscription  My Forums 

Photo Gallery  Member List  Search  Calendars  FAQ  Ticket List  Log Out

How to Enable or Disable Automatically Running CD-ROMs   Logged in as: Guest
Viewers: 1235 You can click here to see Today's Posts | Most Active Topics | Posts Since Last Visit
  Printable Version
All Forums >> [In-House] >> FAQ >> How to Enable or Disable Automatically Running CD-ROMs Page: [1]
Login
Message << Older Topic   Newer Topic >>
How to Enable or Disable Automatically Running CD-ROMs - 5/12/2004 4:54:14 PM   
emperor


Posts: 7210
Joined: 4/28/2004
Status: offline
Taken from Microsoft's Library:

There is no option to enable or disable automatically running CD-ROMs in the user interface. To enable or disable automatically running CD-ROMs, you must edit the registry:

Click Start, click Run, type regedit in the Open box, and then press ENTER.
Locate and click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1.
Restart your computer.

NOTE: This method disables automatically running CD-ROMs. If you want to disable automatically running CD-ROMs depending on the CD-ROM that you insert in the CD-ROM drive, you can press and hold down one of the SHIFT key while you insert the CD-ROM.

Additional Information

There are two other registry keys that can affect this functionality:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

-and-

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

The correct value for each is 0x00000095.
Post #: 1
RE: How to Enable or Disable Automatically Running CD-ROMs - 5/23/2004 1:00:09 PM   
SoBal

 

Posts: 15
Joined: 7/6/2003
From: Poland
Status: offline
This seems to be a huge problem with this one, and it is a good oprotunity to try it now. We have noticed, that on some Windows XP PCs there is a problem with refreshing a CD/DVD contencts. It happens only with nForce mobos and autorun disabled in the way you have mentioned above. If you have accesed CD let's say AAA, and replaced it with BBB and try to access it - you will see dir structure from AAA. The only way to refresh is to open the tray, place media, and try to access the drive so the tray closes and drive starts to read. Ofcourse you can reboot the PC to get the same result. I'm opened to every possible solution, because I have not found any.

(in reply to emperor)
Post #: 2
RE: How to Enable or Disable Automatically Running CD-ROMs - 5/23/2004 1:15:12 PM   
Laffin Assassin


Posts: 4648
Status: offline
Hi SoBal and Welcome to Our Forum !!!
Yes this is a known issue with the NForce Motherboards it is usualy down to the Pathetic NForce IDE Drivers so one way to stop this happening is to uninstall all the NForce IDE Drivers restart your computer and then let Windows XP install its own Default IDE Drivers and most times this Cures the problem !!!


_____________________________

Speaking Without Thinking, Is Like Shooting Without Aiming !!!

(in reply to SoBal)
Post #: 3
RE: How to Enable or Disable Automatically Running CD-ROMs - 5/23/2004 1:31:35 PM   
SoBal

 

Posts: 15
Joined: 7/6/2003
From: Poland
Status: offline
Hey LA!
Exactly, but it comes even with a version 2.42 of nF drivers which does not contain IDE drivers from nvidia.

I have made mistake few months ago - when 3.13 was out, and clicked YES - to install IDE drivers, there were no way back. As you know curiosity killed the cat, so it has killed my OS :) I had to reinstall first time sice a year. After 4.x comes out it has much more stable IDE drivers, but there is a problem with ASPI libraries using this one. Damn nv.

Most probably it is a problem of refreshing some cache memory. Maybe the way would be to use a softice or other debuger to find a memory adress where this information is stored, and after that try to find a library corresponding to it....

(in reply to Laffin Assassin)
Post #: 4
RE: How to Enable or Disable Automatically Running CD-ROMs - 5/23/2004 3:29:23 PM   
Jimmys


Posts: 421
Joined: 7/3/2003
From: Greece
Status: offline
In case you dont want to mess with the registry
point to
Start-> Run and type gpedit.msc
At the group policy window expand the user configuration menu and then navigate to Administration Templates-> System
On the right side enable the Turn Off Autoplay option

(in reply to SoBal)
Post #: 5
RE: How to Enable or Disable Automatically Running CD-ROMs - 5/23/2004 8:25:07 PM   
Laffin Assassin


Posts: 4648
Status: offline
Hi Again SoBal
What version of ASPI are you using as anything later than 4.60 is not very Stable with Windows XP so if you are using a later version I suggest you downgrade to 4.60 and if you don't have the 4.60 let me know and I will tell you where my ASPI FIX is !!!


_____________________________

Speaking Without Thinking, Is Like Shooting Without Aiming !!!

(in reply to Jimmys)
Post #: 6
RE: How to Enable or Disable Automatically Running CD-ROMs - 5/23/2004 11:16:01 PM   
Cal 01


Posts: 111
Joined: 4/28/2004
From: Norfolk, VA, USA
Status: offline
quote:

ORIGINAL: emperor

Taken from Microsoft's Library:

There is no option to enable or disable automatically running CD-ROMs in the user interface. To enable or disable automatically running CD-ROMs, you must edit the registry:

Click Start, click Run, type regedit in the Open box, and then press ENTER.
Locate and click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1.
Restart your computer.

NOTE: This method disables automatically running CD-ROMs. If you want to disable automatically running CD-ROMs depending on the CD-ROM that you insert in the CD-ROM drive, you can press and hold down one of the SHIFT key while you insert the CD-ROM.

Additional Information

There are two other registry keys that can affect this functionality:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

-and-

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

The correct value for each is 0x00000095.



For those who don't feel safe about editing the registry you can use this app http://www.freshdiagnose.com/downfiles.html "FreshUI" (Free) to do the above and you can disable "Win XP integraded CD burning feature."


_____________________________

"What you don't know WILL hurt you in time!"


Regards
Cal
clawso1

(in reply to emperor)
Post #: 7
Page:   [1]
All Forums >> [In-House] >> FAQ >> How to Enable or Disable Automatically Running CD-ROMs Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.047