CDRInfo Forum CDRInfo Forum

Forums  Register  Login  My Profile  Inbox  Address Book  My Subscription  My Forums 

Photo Gallery  Member List  Search  Calendars  FAQ  Ticket List  Log Out

Rimage 2000i   Logged in as: Guest
Viewers: 721 You can click here to see Today's Posts | Most Active Topics | Posts Since Last Visit
  Printable Version
All Forums >> [PC hardware] >> General Hardware Issues >> Rimage 2000i Page: [1]
Login
Message << Older Topic   Newer Topic >>
Rimage 2000i - 3/7/2007 2:57:25 PM   
HHmedia

 

Posts: 2
Joined: 3/7/2007
Status: offline
I have a Rimage 2000i that I bought to replace what i THOUGHT was a broken 360i. After installing the 2000i, I'm having the same problem with it, leading me to believe it's a USB or driver issue.

Basically, whenever I install both machines (falling 100% full recommended procedure), then run QuickDisc, it fails to find my rimage system. When I look for them in the 'updater' utility, it can't find them then either. In DeviceManager I can see both drives, so my assumption is that whatever is supposed to handle the autoloader is the problem.

Any advice?
Post #: 1
RE: Rimage 2000i - 4/2/2007 9:05:27 PM   
williamT

 

Posts: 3
Joined: 4/2/2007
Status: offline
My advise, sell it.


I have had major problems in getting responses from tech support at Rimage for my 2000i. Both in non response with emails and telephone calls. Finally after 2.5 weeks of no response and calling the sales department I received a call 3 days later promising to have someone call that day. No one called. After calling again the next day someone from Rimage did call me back. After spending over two hours on the phone the Rimage unit worked HOWEVER in the process of "fixing" the rimage software my external firewire drives would not mount, which they did before following all of the techs instructions. So, now I own a Rimage 2000i that I cannot use due to my audio data drives cannot be accessed. The Rimage tech said it sounds like a windows problem (which I did not have before his "help"). I have spent so much time trying to get it running that I have given up and am looking at other manufacturers to change to. Chalk up a loss of $3k... my opinion is do not buy a Rimage product!

(in reply to HHmedia)
Post #: 2
RE: Rimage 2000i - 4/2/2007 9:23:10 PM   
HHmedia

 

Posts: 2
Joined: 3/7/2007
Status: offline
Actually Rimage helped me fix the problem (it was an OS driver issue) and upgraded my equipment for free. I'd recommend working with them if you have a problem, they will definitely see you through it and make sure you're well off in the end.

They may be a small company, and therefore experience some communications issues, but I'm extremely satisfied with my dealings now that its all said and done and my machine works properly. Their tech support diagnosed the problem as being with their hardware initially, which it wasnt, and so I can't blame them for the problems. They took blame for something that was my fault (well, my OS's fault) not theirs. Rimage helped more than most companies would have, and now everything works great - AND i have better equipment, all thanks to them.

(in reply to williamT)
Post #: 3
Page:   [1]
All Forums >> [PC hardware] >> General Hardware Issues >> Rimage 2000i Page: [1]
Jump to:





New Messages No New Messages
Hot Topic w/ New Messages Hot Topic w/o New Messages
Locked w/ New Messages Locked w/o New Messages
 Post New Thread
 Reply to Message
 Post New Poll
 Submit Vote
 Delete My Own Post
 Delete My Own Thread
 Rate Posts




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI

0.032