How to Enable or Disable Automatically Running CD-ROMs (Full Version)

All Forums >> [In-House] >> FAQ



Message


emperor -> How to Enable or Disable Automatically Running CD-ROMs (5/12/2004 4:54:14 PM)

Taken from Microsoft's Library:

There is no option to enable or disable automatically running CD-ROMs in the user interface. To enable or disable automatically running CD-ROMs, you must edit the registry:

Click Start, click Run, type regedit in the Open box, and then press ENTER.
Locate and click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1.
Restart your computer.

NOTE: This method disables automatically running CD-ROMs. If you want to disable automatically running CD-ROMs depending on the CD-ROM that you insert in the CD-ROM drive, you can press and hold down one of the SHIFT key while you insert the CD-ROM.

Additional Information

There are two other registry keys that can affect this functionality:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

-and-

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

The correct value for each is 0x00000095.




SoBal -> RE: How to Enable or Disable Automatically Running CD-ROMs (5/23/2004 1:00:09 PM)

This seems to be a huge problem with this one, and it is a good oprotunity to try it now. We have noticed, that on some Windows XP PCs there is a problem with refreshing a CD/DVD contencts. It happens only with nForce mobos and autorun disabled in the way you have mentioned above. If you have accesed CD let's say AAA, and replaced it with BBB and try to access it - you will see dir structure from AAA. The only way to refresh is to open the tray, place media, and try to access the drive so the tray closes and drive starts to read. Ofcourse you can reboot the PC to get the same result. I'm opened to every possible solution, because I have not found any.




Laffin Assassin -> RE: How to Enable or Disable Automatically Running CD-ROMs (5/23/2004 1:15:12 PM)

Hi SoBal and Welcome to Our Forum !!! [:)]
Yes this is a known issue with the NForce Motherboards it is usualy down to the Pathetic NForce IDE Drivers so one way to stop this happening is to uninstall all the NForce IDE Drivers restart your computer and then let Windows XP install its own Default IDE Drivers and most times this Cures the problem !!! [:)]




SoBal -> RE: How to Enable or Disable Automatically Running CD-ROMs (5/23/2004 1:31:35 PM)

Hey LA!
Exactly, but it comes even with a version 2.42 of nF drivers which does not contain IDE drivers from nvidia.

I have made mistake few months ago - when 3.13 was out, and clicked YES - to install IDE drivers, there were no way back. As you know curiosity killed the cat, so it has killed my OS :) I had to reinstall first time sice a year. After 4.x comes out it has much more stable IDE drivers, but there is a problem with ASPI libraries using this one. Damn nv.

Most probably it is a problem of refreshing some cache memory. Maybe the way would be to use a softice or other debuger to find a memory adress where this information is stored, and after that try to find a library corresponding to it....




Jimmys -> RE: How to Enable or Disable Automatically Running CD-ROMs (5/23/2004 3:29:23 PM)

In case you dont want to mess with the registry
point to
Start-> Run and type gpedit.msc
At the group policy window expand the user configuration menu and then navigate to Administration Templates-> System
On the right side enable the Turn Off Autoplay option




Laffin Assassin -> RE: How to Enable or Disable Automatically Running CD-ROMs (5/23/2004 8:25:07 PM)

Hi Again SoBal
What version of ASPI are you using as anything later than 4.60 is not very Stable with Windows XP so if you are using a later version I suggest you downgrade to 4.60 and if you don't have the 4.60 let me know and I will tell you where my ASPI FIX is !!!




Cal 01 -> RE: How to Enable or Disable Automatically Running CD-ROMs (5/23/2004 11:16:01 PM)

quote:

ORIGINAL: emperor

Taken from Microsoft's Library:

There is no option to enable or disable automatically running CD-ROMs in the user interface. To enable or disable automatically running CD-ROMs, you must edit the registry:

Click Start, click Run, type regedit in the Open box, and then press ENTER.
Locate and click the following registry key:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\CDRom

To disable automatically running CD-ROMs, change the Autorun value to 0 (zero). To enable automatically running CD-ROMs, change the Autorun value to 1.
Restart your computer.

NOTE: This method disables automatically running CD-ROMs. If you want to disable automatically running CD-ROMs depending on the CD-ROM that you insert in the CD-ROM drive, you can press and hold down one of the SHIFT key while you insert the CD-ROM.

Additional Information

There are two other registry keys that can affect this functionality:
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

-and-

HKEY_USERS\.DEFAULT\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
NoDriveTypeAutoRun = 0x00000095

The correct value for each is 0x00000095.



For those who don't feel safe about editing the registry you can use this app http://www.freshdiagnose.com/downfiles.html "FreshUI" (Free) to do the above and you can disable "Win XP integraded CD burning feature." [;)]




Page: [1]

Valid CSS!




Forum Software © ASPPlayground.NET Advanced Edition 2.4.5 ANSI
0.0234375